Léon 发表于 2011-7-29 23:18:09

关于Xampp-1.7.4安装Mediawiki-1.17

已经完成了Mediawiki的安装,但是安装时遇到了几个警告,不解决心里不痛快。

比如这一个:Warning: Could not find eAccelerator, APC, XCache or WinCache. Object caching is not enabled.

在网上搜索了一下,找到了解决方案如下:

XAMPP comes with support for eAccelerator out of the box, but unfortunately, the 1.7.4 build of XAMPP leaves out the DLL that's required. To get eAccelerator working, follow these steps:
1.        Download the DLL from http://eac.qme.nl/eAccelerator_v1_0_svn427_for_v5_3_5-VC6.zip
2.        Copy eAccelerator_ts.dll to C:/xampp/php/ext/php_eaccelerator.dll
3.        Uncomment this line in C:/xampp/php/php.ini:
;zend_extension = "C:\xampp\php\ext\php_eaccelerator.dll"
4.        Restart apache
To verify that it is on:
1.        Go to localhost/xampp
2.        Click on phpinfo() from the left sidebar
3.        Ctrl+F for eaccelerator. If you get no results, eAccelerator is not active


安装后在XAMPP的后台看见了如下图片:


理论上来说,eaccelerator应该已经安装成功了,但是再次启动安装,MediaWiki仍然抱出了找不到这个组件的警告。不太明白错在哪里,不知道是否有哥们能解答?

Léon 发表于 2011-8-5 22:18:15

没搞定这个问题,最后换成XAMPP1.6.8解决。
1.7.4这个版本太新了,兼容工作做的不彻底,个人还是推荐1.7.1以前的版本。

魔龙天神 发表于 2011-8-10 08:51:57

谢谢分享!!











static/image/common/sigline.gif

http://img2081.poco.cn/mypoco/myphoto/20110719/00/6035253720110719001551028.png
页: [1]
查看完整版本: 关于Xampp-1.7.4安装Mediawiki-1.17

美国主机评测网站